Sign in to follow this  
Followers 0
spadekevin

would it be silly to send a kayak back to a dealer to redo wiring ????

1 post in this topic

Hello,
I have a new 2009 Revo, and went to plug in my fishfinder (Eagle 250) and it would not turn on. My 2ND TIME USING IT!! I checked the obvious stuff, battery power and correct connections. However, there were 2 things i noticed that might be a problem. #1) The dealer install cut a little opening for wires to go out from the battery inside the watertight container, and it looks like it was too tight, and a tiny bit of the red wire is exposed.#2) One of the metal plug-in needles in the fish-finder was bent. I didn't notice this the 1st time, but it worked. I bent it back and plugged/unplugged the wires a few times. It does not appear to be weakened or on the verge of breaking off.

Any help would be greatly appreciated. Obviously something like this I"m on my own with since it would be silly to send a kayak back to a dealer to redo wiring, etc.

Please help.

I didn't find the right solution from the internet.

References:
https://www.hobie.com/forums/viewtopic.php?f=26&t=12499

Data Analysis Example

Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0